AUE(4) Device Drivers Manual AUE(4)
aue - ADMtek AN986/ADM8511 Pegasus family 10/100 USB Ethernet device
aue* at uhub?
acphy* at mii?
bmtphy* at mii?
The aue driver provides support for USB Ethernet adapters based on the
ADMtek AN986 ("Pegasus") and ADM8511 ("Pegasus II") chipsets. This
includes the following adapters:
Accton SpeedStream Ethernet
Admtek Pegasus II
AEI USB Fast Ethernet
Allied Telesyn AT-USB100
Billionton Systems USB100
Billionton Systems USB100EL
Billionton Systems USB100LP
Billionton Systems USBE100
Corega FEther USB-TX
Corega FEther USB-TXS
ELCON Systemtechnik Goldpfeil P-LAN
Elsa Microlink USB2Ethernet
I/O DATA USB ET/TX
I/O DATA USB ET/TX-S
I/O DATA ETX-US2
Melco Inc. LUA-TX
Melco Inc. LUA2-TX
Mobility EasiDock Ethernet
Omnidirectional Control Technology USB TO Ethernet
Siemens SpeedStream USB
Smartbridges smartNIC 2
The Pegasus family of chipsets contain a 10/100 Ethernet MAC with an MII
interface and are designed to work with both Ethernet and HomePNA
transceivers. Although the chipsets are designed to interface with
100Mbps peripherals, the USB 1.x standards specify a maximum transfer
speed of 12Mbps. Users should therefore not expect to actually achieve
100Mbps speeds with these devices.
The Pegasus chipsets support a 64-bit multicast hash table, single
perfect filter entry for the station address and promiscuous mode.
Packets are received and transmitted over separate USB bulk transfer
The aue driver supports the following media types:
autoselect Enable autoselection of the media type and options. The user
can manually override the autoselected mode by adding media
options to the appropriate hostname.if(5) file.
10baseT Set 10Mbps operation. The mediaopt option can also be used
to enable full-duplex operation. Not specifying full duplex
implies half-duplex mode.
100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option
can also be used to enable full-duplex operation. Not
specifying full duplex implies half-duplex mode.
The aue driver supports the following media options:
Force full duplex operation. The interface will operate in
half duplex mode if this media option is not specified.
For more information on configuring this device, see ifconfig(8).
aue0: watchdog timeout A packet was queued for transmission and a
transmit command was issued, however the device failed to acknowledge the
transmission before a timeout expired.
aue0: no memory for rx list The driver failed to allocate an mbuf for
the receiver ring.
acphy(4), arp(4), bmtphy(4), ifmedia(4), intro(4), netintro(4), usb(4),
ADMtek AN986 and ADM8511 data sheets, http://www.admtek.com.tw.
The aue device driver first appeared in FreeBSD 4.0. OpenBSD support was
added in OpenBSD 2.7.
The aue driver was written by Bill Paul <firstname.lastname@example.org> and
ported to OpenBSD by Aaron Campbell <email@example.com>.
OpenBSD 5.9 November 17, 2013 OpenBSD 5.9
[Unix Hosting |
[Engineering & Automation |
Software Development |