MALO(4) Device Drivers Manual MALO(4)
malo - Marvell Libertas IEEE 802.11b/g wireless network device
malo* at cardbus?
malo* at pci?
malo* at pcmcia?
The malo driver provides support for Marvell Libertas
88W8335/88W8310/88W8385 based PCI/CardBus/PCMCIA network adapters. The
second generation 88W8335/88W8310 chipsets support 802.11b/g.
These are the modes the malo driver can operate in:
BSS mode Also known as infrastructure mode, this is used when
associating with an access point, through which all
traffic passes. This mode is the default.
monitor mode In this mode the driver is able to receive packets without
associating with an access point. This disables the
internal receive filter and enables the card to capture
packets from networks which it wouldn't normally have
access to, or to scan for access points.
The malo driver can be configured to use Wired Equivalent Privacy (WEP)
or Wi-Fi Protected Access (WPA-PSK and WPA2-PSK). WPA is the current
encryption standard for wireless networks. It is strongly recommended
that WEP not be used as the sole mechanism to secure wireless
communication, due to serious weaknesses in it. The malo driver relies
on the software 802.11 stack for both encryption and decryption of data
The malo driver can be configured at runtime with ifconfig(8) or on boot
The driver needs a set of firmware files which are loaded when an
interface is brought up:
These firmware files are not free because Marvell refuses to grant
distribution rights. As a result, even though OpenBSD includes the
driver, the firmware files cannot be included and users have to download
these files on their own.
A prepackaged version of the firmware can be installed using
The following cards are among those supported by the malo driver:
Card Chip Bus Standard
Ambicom WL54CF 88W8385 PCMCIA b/g
I-O DATA WN-G54/CF 88W8385 PCMCIA b/g
Netgear WG511v2 88W8310 CardBus b/g
Netgear WG311v3 88W8335 PCI b/g
SparkLAN WCFM-100 88W8385 PCMCIA b/g
Tenda TWL541C 88W8310 CardBus b/g
Tenda TWL542P 88W8335 PCI b/g
The following example scans for available networks:
# ifconfig malo0 scan
The following hostname.if(5) example configures malo0 to join network
"mynwid", using WPA key "mywpakey", obtaining an IP address using DHCP:
nwid mynwid wpakey mywpakey
arp(4), cardbus(4), ifmedia(4), intro(4), netintro(4), pci(4),
The malo driver first appeared in OpenBSD 4.1.
The malo driver was written by Claudio Jeker and Marcus Glocker.
WPA encryption is not supported for PCMCIA devices.
OpenBSD 6.4 July 15, 2018 OpenBSD 6.4
[Unix Hosting |
[Engineering & Automation |
Software Development |