HIER(7) OpenBSD Reference Manual HIER(7)
hier - layout of filesystems
A sketch of the filesystem hierarchy.
/ Root directory.
/altroot/ Alternate (backup) location for the root (`/') filesystem (see
/bin/ User utilities fundamental to both single and multi-user
environments. These programs are statically compiled and
therefore do not depend on any system libraries to run.
/bsd Pure kernel executable (the operating system loaded into
memory at boot-time).
/bsd.mp Pure kernel executable for multiprocessor machines.
/bsd.rd Installation kernel. The built-in RAM disk contains utilities
which can be run without an external file system, so this
kernel is useful for limited system maintenance too.
/bsd.sp Pure kernel executable for single processor machines.
/dev/ Block and character device files.
MAKEDEV Script for creating device files (see MAKEDEV(8)).
fd/ File descriptor files (see fd(4)).
/emul/ Base directory for alternate areas searched first when system
call emulation is in effect.
/etc/ System configuration files and scripts.
localtime Local time zone information (see ctime(3)).
X11/ Configuration files for the X11 window system.
afs/ AFS configuration files.
amd/ Contains map files for amd(8).
authpf/ Configuration files for the authenticating
gateway user shell (see authpf(8)).
disklabels/ Backup disklabels (see disklabel(8)).
firmware/ Firmware files for various devices.
fonts/ Configuration files for X11 window system
hotplug/ Scripts for the hotplug daemon, hotplugd(8).
iked/ Configuration files for iked(8).
isakmpd/ Configuration files for isakmpd(8).
kerberosV/ Configuration files for the Kerberos version V
subsystem (see kerberos(8)).
ldap/ Certificates and schema definition files for
mail/ sendmail(8) configuration files (including
mtree/ mtree configuration files (see mtree(8)).
ppp/ pppd configuration files (see pppd(8)).
raddb/servers/ List of radius servers and their associated
shared secrets for login_radius(8).
rc.d/ packages(7) start/stop scripts and subroutines
skel/ Example `.' (dot) files for new accounts.
skey/ One-time password user database for skey(1).
sliphome/ Configuration files for sliplogin(8).
ssh/ Configuration files for ssh(1) and sshd(8).
ssl/ OpenSSL configuration files (see openssl(1)).
systrace/ Sample systrace(1) policies.
/home/ Default location for user home directories.
/mnt/ Empty directory commonly used by system administrators as a
temporary mount point.
/root/ Default home directory for the superuser.
/sbin/ System programs and administration utilities fundamental to
both single and multi-user environments. These programs are
statically compiled and therefore do not depend on any system
libraries to run.
/stand/ Programs used in a stand-alone environment.
/tmp/ Temporary files that are not preserved between system reboots.
Periodically cleaned by daily(8).
/usr/ Contains the majority of user utilities and applications.
X11R6/ Files required for the X11 window system.
bin/ X11 binaries.
include/ X11-specific C include files.
lib/ X11 archive libraries.
X11/ Default configuration files
for X11 and companion
modules/ Various libraries and drivers
for the X11 window system.
pkgconfig/ Package metadata for
xorg/ Data files used by the X
man/ X11 manual pages.
share/ Architecture independent data files.
bin/ Common utilities, programming tools, and
games/ Useful and semi-frivolous programs.
include/ Standard C include files.
altq/ C include files for the altq subsystem
arpa/ C include files for Internet service
crypto/ C include files for the cryptographic
ddb/ C include files for the kernel debugger
dev/ Device-specific C include files.
g++/ Include files for the GNU C++ compiler.
isofs/ C include files for the ISO standard
file systems (currently only cd9660).
kerberosV/ C include files for the KerberosV
authentication subsystem (see
libmilter/ C include files for the sendmail(8) mail
machine/ Machine specific C include files.
miscfs/ C include files for miscellaneous file
net/ Miscellaneous network C include files.
net80211/ C include files for 802.11 wireless
netbt/ C include files for the Bluetooth
netinet/ C include files for Internet standard
protocols (see inet(4)).
netinet6/ C include files for Internet protocol
version 6 (see inet6(4)).
netmpls/ C include files for the MPLS protocol.
netnatm/ C include files for native mode ATM
nfs/ C include files for NFS (Network File
objc/ C include files for GNU Objective-C.
openssl/ C include files for the OpenSSL library
protocols/ C include files for Berkeley service
readline/ C include files for the readline(3)
rpc/ C include files for remote procedure
calling (see rpc(5)).
rpcsvc/ C include files for rpcsvc.
scsi/ SCSI-specific C include files.
sys/ System C include files (kernel data
ufs/ C include files for UFS (the U-word File
uvm/ C include files for the virtual memory
xfs/ C include files for the XFS file system.
lib/ System libraries. See intro(3) for a description of
libdata/ Miscellaneous utility data files.
cvs/ Placeholder for user contributed cvs(1)
ldscripts/ ELF linker scripts.
lint/ Prebuilt lint(1) libraries.
perl5/ Data files for perl(1).
libexec/ System daemons and utilities (executed by other
auth/ Login scripts used to authenticate
users (for BSD authentication).
cvs/contrib/ User contributed cvs(1) scripts.
lpr/ Contains the lpf filter for lpd(8).
sendmail/ Contains the sendmail(8) binary.
sm.bin/ Binaries to be run by smrsh(8).
smtpd/ Binaries related to smtpd(8).
lkm/ Loadable kernel modules.
local/ Local executables, libraries, etc.
mdec/ Boot-related executables.
obj/ Architecture specific target tree produced by
building the /usr/src tree.
ports/ The OpenBSD ports collection (see ports(7)).
sbin/ System daemons and utilities (executed by users).
share/ Architecture independent data files.
calendar/ Variety of pre-fab calendar files (see
dict/ Word lists (see look(1) and spell(1)).
american Spellings preferred in
british Spellings preferred in
eign List of common words.
propernames List of proper names.
stop Forms that would otherwise
be derivable by spell(1)
from words in the other
files in /usr/share/dict,
but should not be accepted.
web2 Words from Webster's 2nd
web2a Additional words from
words Common words.
papers/ Reference databases.
special/ Custom word lists.
doc/ Miscellaneous documentation.
html/ HTML documentation.
mg/ Tutorial for the mg(1) editor.
games/ ASCII text files used by various games.
info/ Texinfo source files.
lkm/ Example source code implementing several
lkm module types (see lkm(4)).
locale/ Locales for multi-language support.
man/ Manual pages.
man1/ General commands (tools and
man2/ System calls and error numbers.
man3p/ perl(1) programmers' reference
man4/ Special files and hardware
man5/ File formats.
man8/ System maintenance and operation
man9/ Kernel internals.
misc/ Miscellaneous system-wide ASCII text
termcap Terminal characteristics
database (see termcap(5)).
termcap.db Hash database file
terminfo.db Terminal information
pcvtfonts/ Additional i386 console
mk/ Templates for make (see make(1)).
nls/ National Language Support (NLS) catalogs.
sendmail/ Example files for sendmail(8).
snmp/ Data files for snmpd(8).
mibs/ Management Information Base (MIB)
tabset/ Tab description files for a variety of
terminals; used in the termcap file (see
texinfo/ Templates for texinfo(5).
Catalog files for the vi(1) text editor.
zoneinfo/ Time zone configuration information (see
src/ BSD and/or local source files.
bin/ Source for files in /bin.
distrib/ Source for making distribution sets.
etc/ Source for files in /etc.
games/ Source for files in /usr/games.
gnu/ Source for files under GPL or other
include/ Source for files in /usr/include.
kerberosV/ Source for Kerberos version V.
lib/ Source for files in /usr/lib.
libexec/ Source for files in /usr/libexec.
regress/ Regress framework.
sbin/ Source for files in /sbin.
share/ Source for files in /usr/share.
sys/ Kernel source files.
usr.bin/ Source for files in /usr/bin.
usr.sbin/ Source for files in /usr/sbin.
Source for the X11 window system.
xobj/ Architecture specific target tree produced by
building the /usr/xenocara tree.
/var/ Multi-purpose log, temporary, transient, and spool files.
account/ System accounting files.
acct Execution accounting file (see
audit/ Audit logs.
authpf/ PID file for authpf(8).
backups/ Miscellaneous backup files.
crash/ Crash dumps written by savecore(8).
cron/ Spools and configuration files for cron(8) and
atjobs/ at(1) jobs.
tabs/ Individual crontab(1) files.
db/ Miscellaneous, automatically generated system-
specific database files.
empty/ Generic chroot(2) directory.
games/ Miscellaneous game status and log files.
log/ Miscellaneous system log files.
wtmp Login/logout log (see wtmp(5)).
rdist/ Log files for rdist(1).
mail/ User mailbox files.
named/ Chroot directory for named(8).
nsd/ Database and zone files for nsd(8).
quotas/ Filesystem quota information files.
run/ System information files describing various info
about the system since it was booted.
utmp Database of current users (see
sudo/ Timestamps for sudo(8).
rwho/ rwho data files (see rwhod(8), rwho(1), and
spool/ Miscellaneous printer and mail system spooling
clientmqueue/ Mail messages waiting to be
processed by the sendmail
clientmqueue helper task (see
ftp/ Commonly ~ftp; the anonymous ftp
lock/ Lock files for utilities such as
cu(1), tip(1) and uucp.
mqueue/ Undelivered mail queue (see
output/ Line printer spooling directories.
smtpd/ Mail spool for smtpd(8).
uucp/ uucp spool directory.
uucppublic/ Commonly ~uucp; public uucp
tmp/ Temporary files that are kept between system
reboots. Periodically cleaned by daily(8).
www/ ServerRoot point for httpd(8).
yp/ Files for the yp(8) subsystem.
apropos(1), find(1), locate(1), whatis(1), whereis(1), which(1)
A hier manual page appeared in Version 7 AT&T UNIX.
OpenBSD 5.1 September 19, 2011 OpenBSD 5.1
[Unix Hosting |
[Engineering & Automation |
Software Development |