DEV_MKDB(8) OpenBSD System Manager's Manual DEV_MKDB(8)
dev_mkdb - create /dev database
The dev_mkdb command creates a db(3) hash access method database in
``/var/run/dev.db'' which contains the names of all of the character and
block special files in the ``/dev'' directory, using the file type and
the st_rdev field as the key.
Keys are a structure containing a mode_t followed by a dev_t, with any
padding zeroed out. The former is the type of the file (st_mode &
S_IFMT), the latter is the st_rdev field.
/dev device directory
/var/run/dev.db database file
ps(1), stat(2), db(3), devname(3), kvm_nlist(3), ttyname(3), kvm_mkdb(8)
The dev_mkdb command appeared in 4.4BSD.
OpenBSD 5.1 May 31, 2007 OpenBSD 5.1
[Unix Hosting |
[Engineering & Automation |
Software Development |