MOUNT_PROCFS(8) OpenBSD System Manager's Manual MOUNT_PROCFS(8)
mount_procfs - mount the process file system
mount_procfs [-o options] /proc mount_point
The mount_procfs command attaches an instance of the process namespace to
the global filesystem namespace. The conventional mount point is /proc.
This command is normally executed by mount(8) at boot time.
The options are as follows:
Options are specified with a -o flag followed by a comma
separated string of options. See the mount(8) man page for
possible options and their meanings. The following procfs
specific option is also available:
linux Add Linux compatibility links and nodes to procfs.
The root of the process filesystem contains an entry for each active
process. These processes are visible as a directory whose name is the
process's PID. In addition, the special entry curproc references the
Each directory contains several files.
Process command line parameters, separated by NULs.
file A reference to the vnode from which the process text was read.
This can be used to gain access to the process's symbol table, or
to start another copy of the process.
mem The complete virtual memory image of the process. Only those
address which exist in the process can be accessed. Reads and
writes to this file modify the process. Writes to the text
segment remain private to the process.
status The process status. This file is read-only and returns a single
line containing multiple space-separated fields as follows:
o Command name.
o Process ID.
o Parent process ID.
o Process group ID.
o Session ID.
o major,minor of the controlling terminal, or -1,-1 if there is
no controlling terminal.
o List of process flags: ctty if there is a controlling
terminal, sldr if the process is a session leader, or noflags
if neither of the other two flags are set.
o Process start time in seconds and microseconds, comma
o User time in seconds and microseconds, comma separated.
o System time in seconds and microseconds, comma separated.
o Wait channel message.
o Process credentials consisting of the effective user ID and
the list of groups (whose first member is the effective group
ID), all comma separated.
Statistics reported by df(1) on a procfs filesystem will indicate virtual
memory used/available instead of `disk space', and the number of process
slots used/allocated instead of `inodes'. The block size of the
filesystem is the system page size.
mount(2), fstab(5), mount(8), umount(8)
The mount_procfs utility first appeared in 4.4BSD.
This filesystem may not be NFS-exported since most of the functionality
of procfs requires that state be maintained.
OpenBSD 5.1 December 28, 2011 OpenBSD 5.1
[Unix Hosting |
[Engineering & Automation |
Software Development |