RC.CONF(8) OpenBSD System Manager's Manual RC.CONF(8)
rc.conf, rc.conf.local - system daemon configuration database
This file contains a series of Bourne-shell syntax assignments that are
used to configure the system daemons. It is not read by the kernel, but
is sourced by various other files in the /etc/rc.* series in order to set
shell variables used therein to control the behaviour of the scripts.
It is advisable to leave the /etc/rc.conf file untouched, and instead
create and edit a new /etc/rc.conf.local file. Variables set in this
file will override variables previously set in /etc/rc.conf.
There are four sections in this file. The first is used to turn features
on or off. For example, whether the system runs the dhcpd daemon is
determined by the line in this section
dhcpd_flags=NO # for normal use: ""
If this line is edited to contain some valid dhcpd daemon command-line
flags, such as
dhcpd_flags="-A abandoned" # for normal use: ""
then the dhcpd daemon will be started with those options.
The second section contains some other programs that can either be run or
not, but that don't need options. They can be set to YES or NO. For
example, the line
prevents the NFS server daemons from starting. To run NFS, just change
this line's value from NO to YES, and also make whatever changes are
needed for the server to have something to do (set up the exports(5) file
The third section contains values that parameterize servers started by
one of the first two sections, and are ignored if the corresponding
server is not running. For example, if nfs_server, is enabled, then the
provides command-line arguments for the NFS server.
This particular line instructs nfsd(8) to start four copies of the
server. On a busy file server, 8 (or more) copies are recommended.
The fourth section contains the pkg_scripts variable, responsible for
starting and stopping rc.d(8) scripts installed by packages in the
specified order. For example, the following line
will run /etc/rc.d/dbus_daemon then /etc/rc.d/cupsd with the start
argument at boot time and in reverse order with the stop argument at
init(8), intro(8), rc(8)
The rc.conf file first appeared in OpenBSD 2.2.
OpenBSD 5.1 July 8, 2011 OpenBSD 5.1
[Unix Hosting |
[Engineering & Automation |
Software Development |