NETSTART(8) System Manager's Manual NETSTART(8)
netstart - command script for network startup
/etc/netstart [[-n] interface ...]
netstart is the command script that is invoked by rc(8) during an
automatic reboot and after single-user mode is exited; it performs
The netstart script can also be used to start newly created bridges or
interfaces, or reset existing interfaces to their default state. The
behaviour of this script is (or can be) controlled to some extent by
variables defined in rc.conf(8), which specifies which daemons and
services are to be run.
During the system boot, netstart is executed. netstart performs the
following operations, in the sequence given:
o Set the machine's name.
o Configure the loopback interface.
o Configure all the physical interfaces.
o Configure the following non-physical interfaces: trunk(4),
vlan(4), pfsync(4), and carp(4).
o Initialize the routing table and set up the default routes.
o Configure the remaining non-physical interfaces: pppoe(4),
gif(4), and gre(4).
o Configure all bridge(4) interfaces.
After the system is completely initialized, it is possible to start a
newly created interface or bridge(4), or reset an existing interface to
its default state, by invoking the following, where foo0 is the interface
or bridge name:
# sh /etc/netstart foo0
Using the -n option reports the steps that would be taken, without
actually configuring the interface.
multicast(4), defaultdomain(5), hostname.if(5), myname(5), ifconfig(8),
The netstart command first appeared in 4.0BSD.
OpenBSD 6.4 March 7, 2018 OpenBSD 6.4
[Unix Hosting |
[Engineering & Automation |
Software Development |